Naar inhoud

Nederlandse website wordt kwetsbaar door verouderde webtaal

Nietsvermoedende bezoekers aan een aanzienlijk deel van de Nederlandse websites lopen gevaar wanneer de beheerders niet voor 1 januari 2019 de beheerders overstappen op een nieuwe hoofdversie van de webtaal PHP. Dit is een van de meest gebruikte programmeertalen voor het bouwen van websites. Meer dan drie kwart van de websites die op deze taal zijn gebaseerd, werken met een versie die na 31 december 2018 niet meer van de benodigde beveiligingsupdates wordt voorzien.

Dit blijkt uit cijfers die het IT-magazine AG Connect heeft opgevraagd bij SIDN Labs, de beheerder van het .nl-domein. Bezoekers van de sites die nog op de oude versie draaien, lopen het risico gehackt te worden of daar virussen of andere malware op te lopen. Beveiligingslekken die in de webtaal worden ontdekt, worden dan immers niet meer gerepareerd en bieden kwaadwillenden de ruimte.

Het laatste uitstel is nu echt geweest

De aanhoudende populariteit van versie 5.6 van de PHP-webtaal was vorig jaar al aanleiding voor een uitstel van het zogeheten end of life van deze versie, de datum dat de ontwikkelaars het onderhoud staken. Overschakeling naar de nieuwste versie hoeft de beheerders van de websites niet veel moeite te kosten. Alle hostingbedrijven die de infrastructuur beheren waarop de websites draaien, bieden de nieuwste versie (7.2) aan. “Toch zijn de beheerders terughoudend”, constateert Sven Visser, voorzitter van de branchevereniging Dutch Hosting Provider Association (DHPA) en mede-eigenaar van hostingbedrijf Cyso. De eigenaren van websites vrezen toch extra werk en kosten, terwijl ze er op korte termijn niet veel mee opschieten.

Onterechte weerstand tegen nieuwe versie

Dat werk valt overigens doorgaans erg mee, stelt Sander Potjer, voorzitter van de organisatie waaronder de Dutch Joomla Community valt. Joomla is een van de belangrijke softwareplatformen waarop websites draaien. Andere platformen zijn bijvoorbeeld WordPress en Drupal. Volgens Potjer is een generieke installatie van Joomla met een druk op de knop aan te passen. Alleen software afkomstig van derde partijen – de zogeheten extensies – kunnen roet in het eten gooien. Maar eigenlijk alle veelgebruikte extensies zijn al lang aangepast, dus als er problemen optreden, betekent dat doorgaans de website-eigenaar de updates van de extensies niet heeft toegepast of verouderde, niet-langer ondersteunde extensies in zijn website gebruikt.

Bron: CustomerTalk
0
Logo CustomerTalk

Cookie-instellingen

CustomerTalk maakt gebruik van cookies voor een optimale gebruikerservaring.

Graag vragen wij je toestemming voor het plaatsen van deze cookies.

Accepteren Meer informatie